Notice: eStatements Customers
Browser and Operating System Support Changes - Effective November 8, 2017


Due to enhanced security Microsoft is discontinuing its support of Transport Layer Security (TLS) version 1.0/1.1.  Microsoft will only be supporting the TLS version 1.2.  In order to continue using Community's eStatement services you will need to verify that the Operating System (OS) and Browsers used to access Community's eStatement services support TLS 1.2 and upgrade if necessary.

The following Browsers and Operating systems support the TLS 1.2 version:

Microsoft Edge, Microsoft IE Desktop and mobile version 11, Firefox 27 and higher, Google Chrome 38 and higher, Mobile Safari versions 5 and higher, Microsoft Windows Server 2008 R2 and higher, Microsoft Windows 7, 8.0, 8.1 and 10.

Microsoft IE Desktop versions 9 and 10 are capable of supporting TLS 1.2 only when run in Windows 7 or newer, but not enabled by default.

Please note that Microsoft Windows Server 2008 and below and Microsoft XP/Vista and below are not compatible versions and will not work with Community's Internet banking or Bill pay services.

How to Enable Transport Security Layer (TLS) 1.2

From within your internet browser select Tools, then Internet Options.  Click on the Advanced Tab, and scroll down to the Security section.  Ensure TLS 1.2 is checked, if not check TLS 1.2 and select Apply, OK.

If you have any additional questions please contact us during normal business hours at 773-685-5300 and ask to speak with a representative in the Online Banking department for assistance.

Financial services provided for local customers. All accounts must be opened in person. Other terms, conditions and restrictions apply.